import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?:^([^\"]*(?:\"[^\"a]*(?=\")\"[^\"]*(?=\"))*\"[^\"a]*)|(?!^)\\G)a([^\"a]*(?:(?=a.*?\")|(?:\"[^\"]*$|\"[^\"]*(?=\")(?:\"[^\"a]*(?=\")\"[^\"]*(?=\"))*\"[^\"a]*)))";
final String string = "Somebody once told me \"apples\" are good for you\n"
+ "=> Somebody once told me \"bpples\" are good for you\n\n"
+ "\"Aardvarks\" make good kebabs\n"
+ "=> \"Abrdvbrks\" make good kebabs\n\n"
+ "The boy said \"aaah!\" when his mom told him he was eating aardvark\n"
+ "=> The boy said \"bbbh!\" when his mom told him he was eating aardvark\n";
final String subst = "$1b$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}