#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?:^([^"]*(?:"[^"a]*(?=")"[^"]*(?="))*"[^"a]*)|(?!^)\G)a([^"a]*(?:(?=a.*?")|(?:"[^"]*$|"[^"]*(?=")(?:"[^"a]*(?=")"[^"]*(?="))*"[^"a]*)))"
Local $sString = "Somebody once told me "apples" are good for you" & @CRLF & _
"=> Somebody once told me "bpples" are good for you" & @CRLF & _
"" & @CRLF & _
""Aardvarks" make good kebabs" & @CRLF & _
"=> "Abrdvbrks" make good kebabs" & @CRLF & _
"" & @CRLF & _
"The boy said "aaah!" when his mom told him he was eating aardvark" & @CRLF & _
"=> The boy said "bbbh!" when his mom told him he was eating aardvark" & @CRLF & _
""
Local $sSubst = "$1b$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)