using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?:^([^""]*(?:""[^""a]*(?="")""[^""]*(?=""))*""[^""a]*)|(?!^)\G)a([^""a]*(?:(?=a.*?"")|(?:""[^""]*$|""[^""]*(?="")(?:""[^""a]*(?="")""[^""]*(?=""))*""[^""a]*)))";
string substitution = @"$1b$2";
string input = @"Somebody once told me ""apples"" are good for you
=> Somebody once told me ""bpples"" are good for you
""Aardvarks"" make good kebabs
=> ""Abrdvbrks"" make good kebabs
The boy said ""aaah!"" when his mom told him he was eating aardvark
=> The boy said ""bbbh!"" when his mom told him he was eating aardvark
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}