import re
regex = re.compile(r"(?s)(?:^([^\"]*(?:\"[^\"a]*(?=\")\"[^\"]*(?=\"))*\"[^\"a]*)|(?!^)\G)a([^\"a]*(?:(?=a.*?\")|(?:\"[^\"]*$|\"[^\"]*(?=\")(?:\"[^\"a]*(?=\")\"[^\"]*(?=\"))*\"[^\"a]*)))")
test_str = ("Somebody once told me \"apples\" are good for you\n"
"=> Somebody once told me \"bpples\" are good for you\n\n"
"\"Aardvarks\" make good kebabs\n"
"=> \"Abrdvbrks\" make good kebabs\n\n"
"The boy said \"aaah!\" when his mom told him he was eating aardvark\n"
"=> The boy said \"bbbh!\" when his mom told him he was eating aardvark\n")
subst = "$1b$2"
result = regex.sub(subst, test_str)
if result:
print(result)