#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http|https|)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?\/[a-zA-Z0-9\-\.]+\.xml"
Local $sString = "https://regex101.com/a.xml" & @CRLF & _
"https://wwww.regex101.com/a.xml" & @CRLF & _
"https://wwww.regex101.com/www/1/4a.xml" & @CRLF & _
"http://wwww.regex101.com/www/1/4a.xml" & @CRLF & _
"https://regex101.com/www/1/4a.xml" & @CRLF & _
"https://wwww.regex101.co/www/1/4a.xml" & @CRLF & _
"http://regex101.co/www/1/4a.xml" & @CRLF & _
"http://regex101.co/1/4a.xml" & @CRLF & _
"http://regex101.co/1/4aasfw/a.xml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")