import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https|)\\:\\/\\/[a-zA-Z0-9\\-\\.]+\\.[a-zA-Z]{2,3}(\\/\\S*)?\\/[a-zA-Z0-9\\-\\.]+\\.xml";
final String string = "https://regex101.com/a.xml\n"
+ "https://wwww.regex101.com/a.xml\n"
+ "https://wwww.regex101.com/www/1/4a.xml\n"
+ "http://wwww.regex101.com/www/1/4a.xml\n"
+ "https://regex101.com/www/1/4a.xml\n"
+ "https://wwww.regex101.co/www/1/4a.xml\n"
+ "http://regex101.co/www/1/4a.xml\n"
+ "http://regex101.co/1/4a.xml\n"
+ "http://regex101.co/1/4aasfw/a.xml";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}