use strict;
my $str = 'https://regex101.com/a.xml
https://wwww.regex101.com/a.xml
https://wwww.regex101.com/www/1/4a.xml
http://wwww.regex101.com/www/1/4a.xml
https://regex101.com/www/1/4a.xml
https://wwww.regex101.co/www/1/4a.xml
http://regex101.co/www/1/4a.xml
http://regex101.co/1/4a.xml
http://regex101.co/1/4aasfw/a.xml';
my $regex = qr/(http|https|)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?\/[a-zA-Z0-9\-\.]+\.xml/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}