// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http|https|)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?\/[a-zA-Z0-9\-\.]+\.xml").unwrap();
let string = "https://regex101.com/a.xml
https://wwww.regex101.com/a.xml
https://wwww.regex101.com/www/1/4a.xml
http://wwww.regex101.com/www/1/4a.xml
https://regex101.com/www/1/4a.xml
https://wwww.regex101.co/www/1/4a.xml
http://regex101.co/www/1/4a.xml
http://regex101.co/1/4a.xml
http://regex101.co/1/4aasfw/a.xml";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}