import Foundation
let pattern = #"(http|https|)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?\/[a-zA-Z0-9\-\.]+\.xml"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://regex101.com/a.xml
https://wwww.regex101.com/a.xml
https://wwww.regex101.com/www/1/4a.xml
http://wwww.regex101.com/www/1/4a.xml
https://regex101.com/www/1/4a.xml
https://wwww.regex101.co/www/1/4a.xml
http://regex101.co/www/1/4a.xml
http://regex101.co/1/4a.xml
http://regex101.co/1/4aasfw/a.xml
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)