re = /(http|https|)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?\/[a-zA-Z0-9\-\.]+\.xml/m
str = 'https://regex101.com/a.xml
https://wwww.regex101.com/a.xml
https://wwww.regex101.com/www/1/4a.xml
http://wwww.regex101.com/www/1/4a.xml
https://regex101.com/www/1/4a.xml
https://wwww.regex101.co/www/1/4a.xml
http://regex101.co/www/1/4a.xml
http://regex101.co/1/4a.xml
http://regex101.co/1/4aasfw/a.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end