#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\((?=[10]{8})(?=.*1.*).{8}\)"
Local $sString = "(11111110)" & @CRLF & _
"(11111101)" & @CRLF & _
"(11111100)" & @CRLF & _
"(11111011)" & @CRLF & _
"(11111010)" & @CRLF & _
"(11111001)" & @CRLF & _
"(11111000)" & @CRLF & _
"(11110111)" & @CRLF & _
"(11110110)" & @CRLF & _
"(11110101)" & @CRLF & _
"(11110100)" & @CRLF & _
"(11110011)" & @CRLF & _
"(11110010)" & @CRLF & _
"(11110001)" & @CRLF & _
"(11110000)" & @CRLF & _
"(01110000)" & @CRLF & _
"(01101110)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")