using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?=[10]{8})(?=.*1.*).{8}\)";
string input = @"(11111110)
(11111101)
(11111100)
(11111011)
(11111010)
(11111001)
(11111000)
(11110111)
(11110110)
(11110101)
(11110100)
(11110011)
(11110010)
(11110001)
(11110000)
(01110000)
(01101110)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}