import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?=[10]{8})(?=.*1.*).{8}\\)";
final String string = "(11111110)\n"
+ "(11111101)\n"
+ "(11111100)\n"
+ "(11111011)\n"
+ "(11111010)\n"
+ "(11111001)\n"
+ "(11111000)\n"
+ "(11110111)\n"
+ "(11110110)\n"
+ "(11110101)\n"
+ "(11110100)\n"
+ "(11110011)\n"
+ "(11110010)\n"
+ "(11110001)\n"
+ "(11110000)\n"
+ "(01110000)\n"
+ "(01101110)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}