use strict;
my $str = '(11111110)
(11111101)
(11111100)
(11111011)
(11111010)
(11111001)
(11111000)
(11110111)
(11110110)
(11110101)
(11110100)
(11110011)
(11110010)
(11110001)
(11110000)
(01110000)
(01101110)
';
my $regex = qr/\((?=[10]{8})(?=.*1.*).{8}\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}