import Foundation
let pattern = #"\((?=[10]{8})(?=.*1.*).{8}\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(11111110)
(11111101)
(11111100)
(11111011)
(11111010)
(11111001)
(11111000)
(11110111)
(11110110)
(11110101)
(11110100)
(11110011)
(11110010)
(11110001)
(11110000)
(01110000)
(01101110)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)