using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?(www\.)?(?:twitter\.com|x\.com)\/@?(\w{1,15})$";
string input = @"http://twitter.com/someuser
https://twitter.com/someuser
https://twitter.com/some_user
https://x.com/someuser
http://x.com/someuser
twitter.com/someuser
x.com/someuser
twitter.com/23123
x.com/this_string_is_bigger_then_15_letters
x.com/213?some=parameter";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}