const regex = /^(?:https?:\/\/)?(www\.)?(?:twitter\.com|x\.com)\/@?(\w{1,15})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(www\\.)?(?:twitter\\.com|x\\.com)\\\/@?(\\w{1,15})$', 'gm')
const str = `http://twitter.com/someuser
https://twitter.com/someuser
https://twitter.com/some_user
https://x.com/someuser
http://x.com/someuser
twitter.com/someuser
x.com/someuser
twitter.com/23123
x.com/this_string_is_bigger_then_15_letters
x.com/213?some=parameter`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}