import re
regex = re.compile(r"^(?:https?:\/\/)?(www\.)?(?:twitter\.com|x\.com)\/@?(\w{1,15})$", flags=re.MULTILINE)
test_str = ("http://twitter.com/someuser\n"
"https://twitter.com/someuser\n"
"https://twitter.com/some_user\n"
"https://x.com/someuser\n"
"http://x.com/someuser\n\n"
"twitter.com/someuser\n"
"x.com/someuser\n\n"
"twitter.com/23123\n"
"x.com/this_string_is_bigger_then_15_letters\n"
"x.com/213?some=parameter")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")