use strict;
my $str = 'http://twitter.com/someuser
https://twitter.com/someuser
https://twitter.com/some_user
https://x.com/someuser
http://x.com/someuser
twitter.com/someuser
x.com/someuser
twitter.com/23123
x.com/this_string_is_bigger_then_15_letters
x.com/213?some=parameter';
my $regex = qr/^(?:https?:\/\/)?(www\.)?(?:twitter\.com|x\.com)\/@?(\w{1,15})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}