$re = '/^(?:https?:\/\/)?(www\.)?(?:twitter\.com|x\.com)\/@?(\w{1,15})$/m';
$str = 'http://twitter.com/someuser
https://twitter.com/someuser
https://twitter.com/some_user
https://x.com/someuser
http://x.com/someuser
twitter.com/someuser
x.com/someuser
twitter.com/23123
x.com/this_string_is_bigger_then_15_letters
x.com/213?some=parameter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);