import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:([\\/≈↓£°!↑]).*?\\1|\\([^()]*\\)|<[^<>]*>)(*SKIP)(*F)|\\s+";
final String string = "↑hey girls↑ can I <join yo:u>\n"
+ "((v: grunts))\n"
+ "!damn shit! got it\n"
+ "I mean /yeah we saw each other at a party:/↓ the other day\n\n"
+ "↑!THAT'S! A WOMAN !THAT'S! A WOMAN↑";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}