use strict;
my $str = '↑hey girls↑ can I <join yo:u>
((v: grunts))
!damn shit! got it
I mean /yeah we saw each other at a party:/↓ the other day
↑!THAT\'S! A WOMAN !THAT\'S! A WOMAN↑';
my $regex = qr/(?:([\/≈↓£°!↑]).*?\1|\([^()]*\)|<[^<>]*>)(*SKIP)(*F)|\s+/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";