$re = '/(?:([\/≈↓£°!↑]).*?\1|\([^()]*\)|<[^<>]*>)(*SKIP)(*F)|\s+/m';
$str = '↑hey girls↑ can I <join yo:u>
((v: grunts))
!damn shit! got it
I mean /yeah we saw each other at a party:/↓ the other day
↑!THAT\'S! A WOMAN !THAT\'S! A WOMAN↑';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;