# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:.*\b)?(\w+)\h*\b2\b.*/\1/gm;t' <<< "2 NO PEMJNUM 2 ALTOGETHER HOW MANY JOBS 216 - 217
1 REFERENCE PERSON 2 SPOUSE 3 CHILD 4 OTHER RELATIVE (PRIMARY FAMILY & UNREL) PRFAMTYP 2 FAMILY TYPE RECODE 155 - 156
5 UNABLE TO WORK PUBUS1 2 LAST WEEK DID YOU DO ANY 184 - 185
2 NO PEIO1COW 2 INDIVIDUAL CLASS OF WORKER CODE 432 - 433"