# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:.*\b)?(\w+)\h*\b2\b.*"
test_str = ("2 NO PEMJNUM 2 ALTOGETHER HOW MANY JOBS 216 - 217\n"
"1 REFERENCE PERSON 2 SPOUSE 3 CHILD 4 OTHER RELATIVE (PRIMARY FAMILY & UNREL) PRFAMTYP 2 FAMILY TYPE RECODE 155 - 156\n"
"5 UNABLE TO WORK PUBUS1 2 LAST WEEK DID YOU DO ANY 184 - 185\n"
"2 NO PEIO1COW 2 INDIVIDUAL CLASS OF WORKER CODE 432 - 433")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.