import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*\\b)?(\\w+)\\h*\\b2\\b.*";
final String string = "2 NO PEMJNUM 2 ALTOGETHER HOW MANY JOBS 216 - 217\n"
+ "1 REFERENCE PERSON 2 SPOUSE 3 CHILD 4 OTHER RELATIVE (PRIMARY FAMILY & UNREL) PRFAMTYP 2 FAMILY TYPE RECODE 155 - 156\n"
+ "5 UNABLE TO WORK PUBUS1 2 LAST WEEK DID YOU DO ANY 184 - 185\n"
+ "2 NO PEIO1COW 2 INDIVIDUAL CLASS OF WORKER CODE 432 - 433";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}