const regex = /^(?:.*\b)?(\w+)\h*\b2\b.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*\\b)?(\\w+)\\h*\\b2\\b.*', 'gm')
const str = `2 NO PEMJNUM 2 ALTOGETHER HOW MANY JOBS 216 - 217
1 REFERENCE PERSON 2 SPOUSE 3 CHILD 4 OTHER RELATIVE (PRIMARY FAMILY & UNREL) PRFAMTYP 2 FAMILY TYPE RECODE 155 - 156
5 UNABLE TO WORK PUBUS1 2 LAST WEEK DID YOU DO ANY 184 - 185
2 NO PEIO1COW 2 INDIVIDUAL CLASS OF WORKER CODE 432 - 433`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);