# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S+) (\S+) (\S+)/$1 - $3 - $2/gmu;t' <<< "привет 2524234234523 15:50:65.77
слово1 слово2 слово3
"