package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+) (\S+) (\S+)`)
var str = `привет 2524234234523 15:50:65.77
слово1 слово2 слово3
`
var substitution = "$1 - $3 - $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}