re = /(\S+) (\S+) (\S+)/m
str = 'привет 2524234234523 15:50:65.77
слово1 слово2 слово3
'
subst = '$1 - $3 - $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result