#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)(\S+) (\S+) (\S+)"
Local $sString = "привет 2524234234523 15:50:65.77" & @CRLF & _
"слово1 слово2 слово3" & @CRLF & _
""
Local $sSubst = "$1 - $3 - $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)