const regex = /(\S+) (\S+) (\S+)/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+) (\\S+) (\\S+)', 'gmu')
const str = `привет 2524234234523 15:50:65.77
слово1 слово2 слово3
`;
const subst = `$1 - $3 - $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);