$re = '/(\S+) (\S+) (\S+)/mu';
$str = 'привет 2524234234523 15:50:65.77
слово1 слово2 слово3
';
$subst = "$1 - $3 - $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;