# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^id(?:_p)?\h+"(.*)"(?:(?:\Rstr(?:\[\d+])?\h*)"")+/$1"$2"/gm;t' <<< "id \"text 1\"
str \"\"
id \"text 2\"
str \"\"
id \"text 3\"
str \"\"
id \"text 4\"
str \"\"
id \"text 5\"
str \"\"
id \"text 6\"
id_p \"text 6-2\"
str[0] \"\"
str[1] \"\""