using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^id(?:_p)?\h+""(.*)""(?:(?:\Rstr(?:\[\d+])?\h*)"")+";
string substitution = @"$1""$2""";
string input = @"id ""text 1""
str ""
id ""text 2""
str ""
id ""text 3""
str ""
id ""text 4""
str ""
id ""text 5""
str ""
id ""text 6""
id_p ""text 6-2""
str[0] ""
str[1] """;
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}