re = /^id(?:_p)?\h+"(.*)"(?:(?:\Rstr(?:\[\d+])?\h*)"")+/m
str = 'id "text 1"
str ""
id "text 2"
str ""
id "text 3"
str ""
id "text 4"
str ""
id "text 5"
str ""
id "text 6"
id_p "text 6-2"
str[0] ""
str[1] ""'
subst = '$1"$2"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result