const regex = /^id(?:_p)?\h+"(.*)"(?:(?:\Rstr(?:\[\d+])?\h*)"")+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^id(?:_p)?\\h+"(.*)"(?:(?:\\Rstr(?:\\[\\d+])?\\h*)"")+', 'gm')
const str = `id "text 1"
str ""
id "text 2"
str ""
id "text 3"
str ""
id "text 4"
str ""
id "text 5"
str ""
id "text 6"
id_p "text 6-2"
str[0] ""
str[1] ""`;
const subst = `$1"$2"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);