import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^id(?:_p)?\\h+\"(.*)\"(?:(?:\\Rstr(?:\\[\\d+])?\\h*)\"\")+";
final String string = "id \"text 1\"\n"
+ "str \"\"\n\n"
+ "id \"text 2\"\n"
+ "str \"\"\n\n"
+ "id \"text 3\"\n"
+ "str \"\"\n\n"
+ "id \"text 4\"\n"
+ "str \"\"\n\n"
+ "id \"text 5\"\n"
+ "str \"\"\n\n"
+ "id \"text 6\"\n"
+ "id_p \"text 6-2\"\n"
+ "str[0] \"\"\n"
+ "str[1] \"\"";
final String subst = "$1\"$2\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}