// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^id(?:_p)?\h+"(.*)"(?:(?:\Rstr(?:\[\d+])?\h*)"")+"#).unwrap();
let string = "id \"text 1\"
str \"\"
id \"text 2\"
str \"\"
id \"text 3\"
str \"\"
id \"text 4\"
str \"\"
id \"text 5\"
str \"\"
id \"text 6\"
id_p \"text 6-2\"
str[0] \"\"
str[1] \"\"";
let substitution = "$1\"$2\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}