#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(sz=\d+)"
Local $sString = "www.somelink/phoyto.jpg/?sz=50" & @CRLF & _
"www.somelink/phoyto.jpg/?sz=500" & @CRLF & _
"www.somelink/phoyto.jpg/?sz=5" & @CRLF & _
"www.somelink/phoyto.jpg/?sz=666"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")