package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(sz=\d+)`)
var str = `www.somelink/phoyto.jpg/?sz=50
www.somelink/phoyto.jpg/?sz=500
www.somelink/phoyto.jpg/?sz=5
www.somelink/phoyto.jpg/?sz=666`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}