const regex = /(sz=\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(sz=\\d+)', 'gm')
const str = `www.somelink/phoyto.jpg/?sz=50
www.somelink/phoyto.jpg/?sz=500
www.somelink/phoyto.jpg/?sz=5
www.somelink/phoyto.jpg/?sz=666`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}