using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(sz=\d+)";
string input = @"www.somelink/phoyto.jpg/?sz=50
www.somelink/phoyto.jpg/?sz=500
www.somelink/phoyto.jpg/?sz=5
www.somelink/phoyto.jpg/?sz=666";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}