import re
regex = re.compile(r"(sz=\d+)", flags=re.MULTILINE)
test_str = ("www.somelink/phoyto.jpg/?sz=50\n"
"www.somelink/phoyto.jpg/?sz=500\n"
"www.somelink/phoyto.jpg/?sz=5\n"
"www.somelink/phoyto.jpg/?sz=666")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")