using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(ejection fraction|L?V?EF)[\s\w:<>=]+(\d\d)[\d-]*%?";
string input = @"Diastolic dysfunction, last ejection fraction =55%
The patient during his hospital stay had an echocardiogram, which showed an ejection fraction of more then 60%
Her ejection fraction remained high with a left ventricular ejection fraction of 70-80.
Ejection fraction was 45%.
An ejection fraction of 84 percent
Overall left ventricular systolic function is low normal (LVEF 50-55%).
Left ventricular wall thickness, cavity size and regional/global systolic function are normal (LVEF >55%)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}