import Foundation
let pattern = #"(?i)(ejection fraction|L?V?EF)[\s\w:<>=]+(\d\d)[\d-]*%?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Diastolic dysfunction, last ejection fraction =55%
The patient during his hospital stay had an echocardiogram, which showed an ejection fraction of more then 60%
Her ejection fraction remained high with a left ventricular ejection fraction of 70-80.
Ejection fraction was 45%.
An ejection fraction of 84 percent
Overall left ventricular systolic function is low normal (LVEF 50-55%).
Left ventricular wall thickness, cavity size and regional/global systolic function are normal (LVEF >55%)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)