# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(ejection fraction|L?V?EF)[\s\w:<>=]+(\d\d)[\d-]*%?"
test_str = ("Diastolic dysfunction, last ejection fraction =55%\n\n"
"The patient during his hospital stay had an echocardiogram, which showed an ejection fraction of more then 60%\n\n"
"Her ejection fraction remained high with a left ventricular ejection fraction of 70-80.\n\n"
"Ejection fraction was 45%.\n\n"
"An ejection fraction of 84 percent\n\n"
"Overall left ventricular systolic function is low normal (LVEF 50-55%).\n\n"
"Left ventricular wall thickness, cavity size and regional/global systolic function are normal (LVEF >55%)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.