import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(ejection fraction|L?V?EF)[\\s\\w:<>=]+(\\d\\d)[\\d-]*%?";
final String string = "Diastolic dysfunction, last ejection fraction =55%\n\n"
+ "The patient during his hospital stay had an echocardiogram, which showed an ejection fraction of more then 60%\n\n"
+ "Her ejection fraction remained high with a left ventricular ejection fraction of 70-80.\n\n"
+ "Ejection fraction was 45%.\n\n"
+ "An ejection fraction of 84 percent\n\n"
+ "Overall left ventricular systolic function is low normal (LVEF 50-55%).\n\n"
+ "Left ventricular wall thickness, cavity size and regional/global systolic function are normal (LVEF >55%)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}