const regex = new RegExp('(?i)(ejection fraction|L?V?EF)[\\s\\w:<>=]+(\\d\\d)[\\d-]*%?', 'gm')
const str = `Diastolic dysfunction, last ejection fraction =55%
The patient during his hospital stay had an echocardiogram, which showed an ejection fraction of more then 60%
Her ejection fraction remained high with a left ventricular ejection fraction of 70-80.
Ejection fraction was 45%.
An ejection fraction of 84 percent
Overall left ventricular systolic function is low normal (LVEF 50-55%).
Left ventricular wall thickness, cavity size and regional/global systolic function are normal (LVEF >55%)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}