#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+<del.*?>.*?<\/del>(\w+)?|(\w+)?<del.*?>.*?<\/del>\w+|(\w+)?<del.*?>.*?<\/del>\w<del.*?>.*?<\/del>(\w+)"
Local $sString = "Tutorial<del class="ice-del">Within word</del> WordEnd Tutorial<del class="ice-del">Within word</del> WordEndsample<del class="ice-del">total word</del>Welcome<del class="ice-del">Within word</del> to RegExr v2.0 by gskinner.com!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")